8mm Forum


Post New Topic  Post A Reply
my profile | my password | register | search | faq | register | forum home
  next oldest topic   next newest topic
» 8mm Forum   » 16mm Forum   » RCA Hollywood

 - UBBFriend: Email this page to someone!    
Author Topic: RCA Hollywood
Terry Sills
Phenomenal Film Handler

Posts: 1402
From: Weymouth,Dorset,England
Registered: Oct 2012


 - posted September 30, 2013 12:22 PM      Profile for Terry Sills   Email Terry Sills   Send New Private Message       Edit/Delete Post 
I have an RCA Hollywood in very good condition and working order but although the amplifier seems good, producing plenty of 'hiss' through the speaker when volume is turned up, there is low volume when a film is run. I've changed the PEC and exciter lamp with no improvement. The lens assembly for the exciter lamp is clean and has not been tampered with and I have cleaned the mirror that directs the beam onto the PEC. All to no avail. When I interupt the beam there seems plenty of the expected 'Whup' from the speaker but it just seems that the light beam is not poweful enough to penetrate the soundtrack of a film enough to give a good volume response. Does anyone have practical experience of this problem or tips that might help?

 |  IP: Logged



All times are Central  
Post New Topic  Post A Reply Close Topic    Move Topic    Delete Topic    next oldest topic   next newest topic
 - Printer-friendly view of this topic
Hop To:

Visit www.film-tech.com for free equipment manual downloads. Copyright 2003-2019 Film-Tech Cinema Systems LLC

Powered by Infopop Corporation
UBB.classicTM 6.3.1.2