8mm Forum


Post New Topic  Post A Reply
my profile | my password | register | search | faq | register | forum home
  next oldest topic   next newest topic
» 8mm Forum   » General Yak   » My Euming S940 has lost power

 - UBBFriend: Email this page to someone!    
Author Topic: My Euming S940 has lost power
Garry Robert Duffield
Junior
Posts: 23
From: Sydney, Australia
Registered: Jul 2013


 - posted July 23, 2013 05:36 AM      Profile for Garry Robert Duffield   Email Garry Robert Duffield   Send New Private Message       Edit/Delete Post 
I have got back into Super 8 due to purchasing a feature
from England recently. My Euming S940 had been sitting in a cupboard since the early ninety's, in a box and foam packaging. Looking almost brand new, apart from two sound dials that have come off. To my dismay(after the film finally arrived) I plugged in the power cord and switched on the power switch....no power.
I tried another power cord knowing that this one works getting it from my set top box, and still no power. Has anyone on the forum had a similar problem, as I'm hoping that it's just a fuse.
Also I live in Sydney, Australia. Does anyone live there and know of a good film projector technician, as I've searched the web and only found one in Dubbo, which is about four hours by train, as I don't have a car. If you can help in any way please post a reply or my email address is garry.duffield@digitalpictures.com.au
Thanks Garry.

 |  IP: Logged

Paul Adsett
Film God

Posts: 4866
From: USA
Registered: Jun 2003


 - posted July 23, 2013 09:38 AM      Profile for Paul Adsett     Send New Private Message       Edit/Delete Post 
Hi Gary,
Your problem is possibly very simple. The main sliding switch on the Eumig 900 series is not the best design. When you slide the black plastic knob to turn on the main power it can often 'skip' over the top of the little button on the actual electrical switch situated undereneath it. Here's what to try:
First push inwards on the black knob as you slide it. This is often enough to engage the underside of the black plastic slide piece with the actual switch situated behind it.
Failing that, remove the lamphouse cover and 'gently' pry the black plastic slide lever off the metal rail. This will reveal the actual main switch. Now you should be able to push the little button side-to-side with a small screwdriver. You may want to put a little alcohol or vaseline onto the switch to help free it up in the event it has seized up through not being used.
Once you get it running, don't use the main switch anymore - just unplug th power lead. These switches have been a problem since day 1 on the Eumig 900's. I had the same problem on my Eumig 938, and now I just leave that switch in the ON position all the time and just power down by unplugging the cord.
The 940 is the best projector Eumig ever made - some might say the best super 8 projector of all. Good luck, and get back if this does not work.

--------------------
The best of all worlds- 8mm, super 8mm, 9.5mm, and HD Digital Projection,
Elmo GS1200 f1.0 2-blade
Eumig S938 Stereo f1.0 Ektar
Panasonic PT-AE4000U digital pj

 |  IP: Logged

Maurice Leakey
Film God

Posts: 5691
From: Bristol. United Kingdom
Registered: Oct 2007


 - posted July 23, 2013 02:30 PM      Profile for Maurice Leakey   Email Maurice Leakey   Send New Private Message       Edit/Delete Post 
The red record button and its switch can also give trouble. No sound on playback.

--------------------
Maurice

 |  IP: Logged



All times are Central  
Post New Topic  Post A Reply Close Topic    Move Topic    Delete Topic    next oldest topic   next newest topic
 - Printer-friendly view of this topic
Hop To:

Visit www.film-tech.com for free equipment manual downloads. Copyright 2003-2019 Film-Tech Cinema Systems LLC

Powered by Infopop Corporation
UBB.classicTM 6.3.1.2