8mm Forum


Post New Topic  Post A Reply
my profile | my password | register | search | faq | register | forum home
  next oldest topic   next newest topic
» 8mm Forum   » 8mm Forum   » 1st Post - Bell and Howell 471Z

 - UBBFriend: Email this page to someone!    
Author Topic: 1st Post - Bell and Howell 471Z
Mark Cerisano
Junior
Posts: 1
From: Montreal, Quebec, Canada
Registered: Nov 2017


 - posted November 19, 2017 08:19 PM      Profile for Mark Cerisano   Author's Homepage   Email Mark Cerisano   Send New Private Message       Edit/Delete Post 
First post here. I hope someone can help.

I have a B&H 471 self threading projector.

It has worked fine for the last two days, then I couldn't thread it.

The black rubber wheel wasn't turning.

I pressed down the back of the threading wheel lever and shone some light inside. I could see some crumpled film. I removed it. There was always this clicking sound which I figured was the broken pieces of film. (The sound is gone now and the films I had watched were a bit slow)

Now the black rubber wheel turns but the film only goes in a short way, I hear that clicking sound again, and when I take the film out it's bent and crumpled.

I figure there's more crumpled film in there somewhere but I can't see it.

How can I take the gear mechanism apart to look?

--------------------
Mark Cerisano, RPT
howtotunepianos.com

 |  IP: Logged



All times are Central  
Post New Topic  Post A Reply Close Topic    Move Topic    Delete Topic    next oldest topic   next newest topic
 - Printer-friendly view of this topic
Hop To:

Visit www.film-tech.com for free equipment manual downloads. Copyright 2003-2019 Film-Tech Cinema Systems LLC

Powered by Infopop Corporation
UBB.classicTM 6.3.1.2