8mm Forum


  
my profile | my password | search | faq | register | forum home
  next oldest topic   next newest topic
» 8mm Forum   » 8mm Forum   » Someone have experience with Agfa F8S Automatic tapesplicer?

 - UBBFriend: Email this page to someone!    
Author Topic: Someone have experience with Agfa F8S Automatic tapesplicer?
Matthieu van der Sluis
Master Film Handler

Posts: 373
From: Barendrecht, The Netherlands
Registered: Aug 2017


 - posted November 17, 2017 04:24 AM      Profile for Matthieu van der Sluis   Author's Homepage   Email Matthieu van der Sluis   Send New Private Message       Edit/Delete Post 
I have a Agfa F8S Automatic tapesplicer and I believe that when it works you can splice abd tape completely by feeling without even looking, but for now I cannot get this to work.

Most of the time it won't cut and only marks my film.
So I bought a new Agfa F8S, (So the man said), which indeed seems new and complete and packed nicely.
Now this one cuts really good, but wont do the taping.

I tried all kind of ways like I've seen in the YouTube films, and in the manual, but I already used more than 50 stickers and only 5 times it worked nicely.

What am I doing wrong?

I place the film like it's suppose to, with the red part in top, pointed to the inside.
I take the handle down and there lies the trick I think,...
- I did this fast, slow.
- Pressing gently, but the tape sticks on the handle
- A bit harder, which bends the film.
- Sometimes the tape is only one sided and partly cut off.

On the new Agfa F8s that cuts real good, but the film stucks onder the clamp and I have to take it out underneed the square clamp.
It is really terrible.

Someone with experience on the F8S who can tell me what I'm doing wrong?

[ November 19, 2017, 09:01 AM: Message edited by: Matthieu van der Sluis ]

 |  IP: Logged

Matthieu van der Sluis
Master Film Handler

Posts: 373
From: Barendrecht, The Netherlands
Registered: Aug 2017


 - posted November 18, 2017 05:01 PM      Profile for Matthieu van der Sluis   Author's Homepage   Email Matthieu van der Sluis   Send New Private Message       Edit/Delete Post 
I changed the title and post, because in the mean time I bought a new one.
So I descibe my problems of now.

 |  IP: Logged



All times are Central  
   Close Topic    Move Topic    Delete Topic    next oldest topic   next newest topic
 - Printer-friendly view of this topic
Hop To:

Visit www.film-tech.com for free equipment manual downloads. Copyright 2003-2019 Film-Tech Cinema Systems LLC

Powered by Infopop Corporation
UBB.classicTM 6.3.1.2