This is topic Problem with my ELMO GS in forum 8mm Forum at 8mm Forum.


To visit this topic, use this URL:
http://8mmforum.film-tech.com/cgi-bin/ubb/ultimatebb.cgi?ubb=get_topic;f=1;t=009949

Posted by Antoine Orsero (Member # 41) on May 05, 2015, 01:04 PM:
 
Hi,
The main motor of my ELMO GS 1200 no longer works. I changed the fuses but it still does not work while the arm engines work well.

I do not know why this happened suddenly
 
Posted by Steve Klare (Member # 12) on May 05, 2015, 02:00 PM:
 
Hi Antoine,

I do not know the GS very well, but if it is anything like other DC motored Elmos I do know it basically comes down to:

-Motor
-Motor control switches
-Motor speed control

If you can get a voltmeter on the motor power leads and try to operate the machine, you will find:

-good voltage (bad motor)
-no voltage (probably a good motor: try something else!)
 
Posted by Antoine Orsero (Member # 41) on May 05, 2015, 03:22 PM:
 
Thanks for your answer.
The motor is good I tested it. It seems to me that this is an electronic problem, but which?
Finally the GS1200 are too delicat because they are full of contacts and electronics. I prefer the ST1200, they are more mechanical.
Best regards
 
Posted by Steve Klare (Member # 12) on May 05, 2015, 03:30 PM:
 
I love the GS the way I love a Ferrari: it's a spectacular machine capable of great performance, but the complexity scares me!

(I may own a GS some day...A Ferrari?, I'm thinking "no!")

If Elmo had done a better job on the speed selector on the ST-1200, it would be twice as good as it is!

If you are lucky, some switch or relay has come to the end of its life and if you can identify it and find a replacement , you will be in business again.

-otherwise there is some pretty complex circuitry regulating the motor speed: many opportunities for trouble!
 
Posted by Antoine Orsero (Member # 41) on May 06, 2015, 03:28 AM:
 
Hi Steve,

I have several spare parts for the GS1200 but I am unable to do the editing. I replaced circuitry regulating the motor speed and the problem has not been resolved.
Here in France, in my city, Marseille, it has not more projector repair.

Fortunately I have another GS1200 projector that works very well two ST1200 and 2 GS800.

Best regard
 
Posted by Steven J Kirk (Member # 1135) on May 06, 2015, 08:49 AM:
 
FFR does sell a replica speed control board, if that helps. Brand new.

http://www.ffr-film.de/index.php?page=elmo&language=eng
 
Posted by Antoine Orsero (Member # 41) on May 06, 2015, 10:26 AM:
 
Hi Steven,

Yes, I know! I have two or three old and new models! But this is not him that causes a problem on my GS1200. There must be more serious about electronics.
 


Visit www.film-tech.com for free equipment manual downloads. Copyright 2003-2019 Film-Tech Cinema Systems LLC

Powered by Infopop Corporation
UBB.classicTM 6.3.1.2