This is topic Elmo FP-C - Green Button Question in forum 8mm Forum at 8mm Forum.


To visit this topic, use this URL:
http://8mmforum.film-tech.com/cgi-bin/ubb/ultimatebb.cgi?ubb=get_topic;f=1;t=012645

Posted by John Berman (Member # 6737) on December 07, 2018, 06:41 AM:
 
Hi

My first post so please be gentle

I have bunch of 8mm Films so recently bought myself a Iflord Elmo FP-C projector from a second hand shop, I have had a good look at it and nothing appears to be broken etc (tested the lamp which is fine.

My only issue so far is the Green Button (not sure of its correct name) it seems stuck in the forward position, i have attempted to push it back but it does not want to move (did not want to push it to hard) looking at the mechanism its not obvious why it stuck, pointers really appreciated
 
Posted by Janice Glesser (Member # 2758) on December 07, 2018, 01:01 PM:
 
Hi John and welcome to the Forum. Have you run film through the projector yet? I believe the green "bottom" you are referring to is the "threading lever." To run the film you first push down the threading lever, then turn the lamp switch to "On." Next set the main motor switch to "Run." Insert the trimmed end of the film into the projector. When the film reaches the take-up reel it will automatically load onto the take-up reel which should cause a slight tug on the film. That tug should disengage the threading lever pulling it back. However, if the film does not autoload onto the reel and you have to thread the reel by hand or if there isn't a tug you can manually turn the take-up reel to the right with your hand to create the tug.

Try this and let us know if this solved the problem.

 -
 
Posted by John Berman (Member # 6737) on December 07, 2018, 01:27 PM:
 
Jancie

Worked a treat, lamp came on and movie played - so exciting to see it work

Thanks so much
 
Posted by Janice Glesser (Member # 2758) on December 07, 2018, 01:57 PM:
 
Great John! Do you need a User Manual? If so...just PM me your email address. I'll send you a PDF.
 
Posted by John Berman (Member # 6737) on December 13, 2018, 10:42 AM:
 
Janice

Cant seem to PM you I get: Sorry, either the user or the board administrator is blocking access to this email address

john
 
Posted by Janice Glesser (Member # 2758) on December 13, 2018, 11:37 AM:
 
Make sure you are clicking on the PM link icon and not the email icon.

 -
 


Visit www.film-tech.com for free equipment manual downloads. Copyright 2003-2019 Film-Tech Cinema Systems LLC

Powered by Infopop Corporation
UBB.classicTM 6.3.1.2