Announcement

Collapse
No announcement yet.

8mm Projector Maintenance

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Simon Wyss
    replied
    Long term solution to that problem is to install an oil lubrication system. It’s the main shaft plus the gearing which turn less freely in the bearings and among themselves. The main shaft runs in four plain bearings. The claw drive should move lightly. Lots of drag come from the take-up mechanism. The main shaft should spin for a second once impelled by hand. After fifty years a projector can’t be expected to work like new.

    Leave a comment:


  • Janice Glesser
    replied
    Shane C. Collins thanks for your post. Your process sounds like a much safer and more effective solution then sanding the discs.

    Leave a comment:


  • Shane C. Collins
    replied
    I'd like to add my solution to this issue concerning the rubber discs. Maurice's link above describes what Paul Adsett did to cure his own issues. Like Paul, I also used CRC automotive belt dressing. Before doing this step, I first cleaned both discs with alcohol using a cotton swab. I applied the alcohol several times to each disc. After this step I then applied the belt dressing. After the initial cleaning, with the belt dressing, I waited about 48 hours, and then applied a second application. To my surprise both discs looked brand new, and the rubber was supple once again. This was several months ago and the projector has not slowed down speed wise.

    Leave a comment:


  • Maurice Leakey
    replied
    Fruma
    Have a look at this.
    8mm Forum: Slipping Eumig Drive Discs (film-tech.com)

    Leave a comment:


  • Brian Fretwell
    replied
    This is usually the slipping of the ball on the rubber drive discs. which is a problem with almost all models of Eumig sound projectors, and has been extensively mentioned in the Super 8 section of this forum. Cures are there too.

    Leave a comment:


  • Fruma Elizabeth
    started a topic 8mm Projector Maintenance

    8mm Projector Maintenance

    Hi! First post on here, hoping I’m doing it right.

    I have a Eumig Mark S 810 8mm projector, and I’ve been having an issue with it that I’m at a loss to figure out. As it runs, the playback of films gradually slows down. This isn’t much of a problem for silent pictures, as the change is usually not visible, but when playing films with sound the effect is very dramatic.
    I’ve observed it happening closely, and it appears to affect everything in the projector at once (the shutter and shuttle both slow down, as well as the rotation of the supply and takeup reels), so I can be reasonably certain its not a problem with the sound components themselves.
    The issue is that I haven’t been able to find any other instances of this happening online, or any comprehensive details about projector maintenance. granted I haven’t been looking very long, as I’ve only just started getting into film, but its still confounding. Does anybody have any advice or research pointers?
Working...
X