8mm Forum


  
my profile | my password | search | faq | register | forum home
  next oldest topic   next newest topic
» 8mm Forum   » 8mm Forum   » Elmo FP A

 - UBBFriend: Email this page to someone!    
Author Topic: Elmo FP A
Bill Trandum
Junior
Posts: 2
From: Vaughn, WA, USA
Registered: Mar 2015


 - posted March 04, 2015 04:03 PM      Profile for Bill Trandum   Email Bill Trandum   Send New Private Message       Edit/Delete Post 
My 1965 model FP A will not power up. It acts as if it has a blown fuse but nowhere can I find a fuse. Any ideas on what might be causing it to act dead?

--------------------
Btrandum

 |  IP: Logged

Janice Glesser
Film Goddess

Posts: 3468
From: Sunnyvale, CA USA
Registered: Sep 2011


 - posted March 05, 2015 12:12 AM      Profile for Janice Glesser   Email Janice Glesser   Send New Private Message       Edit/Delete Post 
Welcome to the forum Bill.

Does the lamp go on?

Make sure the Auto Start button is turned off and speed dial is not in the ETS area.

 -

--------------------
Janice

"I'm having a very good day!"
Richard Dreyfuss - Let It Ride (1989).

 |  IP: Logged

Bill Trandum
Junior
Posts: 2
From: Vaughn, WA, USA
Registered: Mar 2015


 - posted March 05, 2015 12:26 PM      Profile for Bill Trandum   Email Bill Trandum   Send New Private Message       Edit/Delete Post 
Thank you so much. The speed control knob was loose and doing nothing. So we fixed that but even more importantly the doggoned gfi breaker on the circuit had tripped so it was getting no power through the cord. We started examining everything closely based on your advice. Again, thank you. My wife and I celebrate our fiftieth on a march 13 and now can celebrate with our kids and grandkids by watching 1965-1970 movies.

--------------------
Btrandum

 |  IP: Logged

Janice Glesser
Film Goddess

Posts: 3468
From: Sunnyvale, CA USA
Registered: Sep 2011


 - posted March 05, 2015 12:58 PM      Profile for Janice Glesser   Email Janice Glesser   Send New Private Message       Edit/Delete Post 
Fantastic Bill! Happy Anniversary and so glad you got your projector working. Have fun!

--------------------
Janice

"I'm having a very good day!"
Richard Dreyfuss - Let It Ride (1989).

 |  IP: Logged



All times are Central  
   Close Topic    Move Topic    Delete Topic    next oldest topic   next newest topic
 - Printer-friendly view of this topic
Hop To:

Visit www.film-tech.com for free equipment manual downloads. Copyright 2003-2019 Film-Tech Cinema Systems LLC

Powered by Infopop Corporation
UBB.classicTM 6.3.1.2