Announcement

Collapse
No announcement yet.

SOUND PROBLEM - Bell and Howell FILMOSONIC DCR super 8 projector

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • SOUND PROBLEM - Bell and Howell FILMOSONIC DCR super 8 projector

    Hello everyone.

    I just bought a Bell and Howell DCR super 8 projector and it plays wonderful but the sound is very low and always with a noise. The volume button appears not to be working. I connected to an external speaker but the noise continues. It's higher than the audio from the movies.

    Can you help?

    VID_20200918_183052.mp4
    Click image for larger version

Name:	119836590_357003115434601_6627943692561931615_n.jpg
Views:	558
Size:	126.2 KB
ID:	17006 Click image for larger version

Name:	119865590_1728393494003024_9025980312440029224_n.jpg
Views:	434
Size:	120.1 KB
ID:	17007

  • #2
    Francisco

    You say the volume control does not appear to be working. It is possible that if not used for many years there may be the need for the carbon track to be self "lubricated". To do this, turn the control quickly forwards and backwards many times.

    With no film in the projector, push the record button many times to "lubricate" the button's contacts.

    Check the sound head to see if it is covered in magnetic oxide. If so, clean carefully with a small amount of isopropyl alcohol on a lint-free cloth.

    If these do not work for you, then there maybe problems with the amplifier.



    Maurice

    Comment


    • #3
      Thanks, Maurice.

      I've done everything you said and still makes that awful sound. It must be the amplifier.

      Francisco

      Comment


      • #4
        Francisco
        I bought an Elmo GS-1200 some years ago and had a similar sound problem with loud screeching which was not altered with the volume control.
        After examination, the solution by an engineer was to replace all the capacitors on the amplifier circuit board.
        It was a big job and I don't recommend it to anyone who does not have the patience, or the skill.
        If you bought on eBay you should try to contact the seller to return for a refund.



        Maurice

        Comment


        • #5
          I would also encourage changing of the caps on the circuit board too.

          Comment


          • #6
            Originally posted by Maurice Leakey View Post
            Francisco
            I bought an Elmo GS-1200 some years ago and had a similar sound problem with loud screeching which was not altered with the volume control.
            After examination, the solution by an engineer was to replace all the capacitors on the amplifier circuit board.
            It was a big job and I don't recommend it to anyone who does not have the patience, or the skill.
            If you bought on eBay you should try to contact the seller to return for a refund.



            Maurice
            Thanks Maurice. I got a refund. I'll try to buy another one. This time in good condition.

            Best,
            Francisco

            Comment


            • #7
              Well done, Francisco, that is good news.

              Maurice

              Comment

              Working...
              X