No announcement yet.

Requesting Elmo GS-1200 Repair Suggestions For Problem Front and Rear Arms

  • Filter
  • Time
  • Show
Clear All
new posts

  • Requesting Elmo GS-1200 Repair Suggestions For Problem Front and Rear Arms


    I have a GS-1200 that I have been using a few times a year. I had run a 800 FT reel without a noticeable problem. The next day I found that when I run a reel, the rear take up reel stops or won't turn at all. Likewise, the front source reel stops when running the film in reverse. You can manually spin the arm and it will go a little, then stop. If I pull out the rewind switch on the front arm, the reel rewinds without a problem.

    As far as I can tell, the motors on the front and rear arms are working. I took the covers off of both arms and the belt and the gears inside the front and rear arms look OK. There is slack in the tractor belt, but it does not slip. The gears in the arm housing do not appear to slip either. When running the projector and the arm stops turning, nothing is spinning inside the arm. Meaning the lowest visible gear is not turning. That seems to imply that the problem is a gear inside the machine.

    Over 10 years ago I replaced the rewind gear in the front arm, which had broken. Looking at the rear arm, it looks like a large amount of work to remove the motor. I am worried it may be too difficult and needs someone with experience to fit it.

    Question: I am I correct thinking it is something inside the unit, between the motor and bottom gear in the arm that is likely the problem?

    Question: I am thinking I would rather have someone repair it than to attempt it myself. I have done some searching but I have not found a place that says they repair the Elmo GS1200 in the US. Can someone recommend a place to repair it in the US?

    Question: When I repaired my rewind years ago, I obtained the part from Leon Norris. However, I have not found a working contact number. Is he still around? I ask because if I cannot find someone to repair it for me, then I will have to attempt it myself and I do not know where else I could get parts.

    Any answers or other advice would be appreciated.

  • #2
    Hi Robert, this is a common problem in the GS1200. One likely root cause is failure of the small control relay on the main circuit board. To replace this you have to get the main board out of the machine which involves a fair amount of disassembly work. Also to desolder and resolder in the new relay you need to be really good at soldering operations as the pins are extremely close together. I do not advise that you attempt this yourself.
    Leon can certainly do the job for you. You can reach him at 610-272-3205.


    • #3
      Hello Paul, Thank you for the confirmation and the phone number. I have tried calling that number yesterday and today and it seems to go to a fax machine. Do you know of a particular time when it is good to call him? Thanks again.


      • #4
        Leon is sometimes like The Scarlett Pimpernell - elusive! I talked to him last week ( Leon loves to talk, so allow yourself about 30 minutes for your call). Try calling him in the evening and leaving a message, if that fails let me know and I will call him myself and let him know you are trying to reach him. I am sure he will be able to fix your GS1200.


        • #5
          Hello Paul, Never mind. I got through and left a message with someone. They were having some kind of phone issue. Thanks again. Hopefully I can get this repaired.


          • #6

            misrouting, sorry


            • #7
              Hi I have this issue but it only is happening a few times when running the projector sort of intensely. Is it the relay issue also when the pick up arms only stalls every once in a while and when you can then make it to work by helping it a bit by hand and then it works again for quite a while?
              or is this another problem? I placed new belts and gears in the arms seem okay. TIA!


              • #8
                Hello to all!
                I had this Problem too with one of my Elmos. First i have checked the Brushes of the take up Motor. They are wearing short over the Years. So I put a Pair of new Brushes in this little Motor and cleaned up everything inside. But the Problem was still there. Next Step I changed the fwd Relay on the Main Board. I got one from Ebay for only 11 Euros new. It is not nessesary to take the main Board out of the Machine. Only the Fan Motor and the Fly Wheel must be take out. I desoldered the Relay and solder the new one into the Board. After this operation everything is working fine.


                • #9
                  Thomas where did you get those brushes? I just broke one doing a clean up of the take up motor commutator.


                  • #10
                    Hi Paul!
                    You canĀ“t get this original Brushes anywhere. But on Ebay you can find a little bit bigger ones. You must make them propper with sanding Paper and then fit them in. It is not an easy Work.


                    • #11
                      Thank's for that info Thomas. At least I know not to search around for identical brushes. Having got the motor apart I need no imagination to realize what a fiddly job it's going to be. Nothing to lose by trying though as the motor is useless right now. I really did not realize how fragile the brushes are, I used just a few more ergs of force than I should have when reassembling the brush assembly over the end of the comutator, and the brush broke off like a stick of chalk!