Announcement

Collapse
No announcement yet.

Elmo K-100SM speed problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Elmo K-100SM speed problem

    This all works fine except the variable speed will not stay at the same speed, it seems to slowly increase on its own and keeps having to be slowed down to the correct speed then a few mins later needs doing again.Any ideas what the problem is?

  • #2
    If my understanding is correct this projector uses universal motor (the one with brushes). While small & powerful, unfortunately this type of motor would have poor speed regulation. It would fluctuate due to LOTs of factor, mechanical load, input voltage, its temperature, etc.

    Therefore you may expect some 5-10% speed variation as being quite normal. In other words - if the speed swings up & down wildly, something is wrong then.

    Comment


    • #3
      You might try adding a little lubricating oil to the motor to see if that helps. Also it may need a new belt and further lubrication on the gears. If it hasn't been used for a while any grease that has hardened over the years can cause speed variations. I have this projector and mine seems to run fairly consistent speed wise.

      As an afterthought you might try some contact cleaner on the rheostat. It may be making intermittent contact.
      Last edited by Janice Glesser; July 18, 2022, 02:48 PM.

      Comment


      • #4
        It only seems to speed up on its own, not slow down, i’ve lubricated all the areas that need doing and fitted a new belt. I haven't sprayed the rheostat though so will try that.

        Comment

        Working...
        X