8mm Forum


  
my profile | my password | search | faq | register | forum home
  next oldest topic   next newest topic
» 8mm Forum   » 8mm Forum   » Elmo TRV-S8 belts problem?

 - UBBFriend: Email this page to someone!    
Author Topic: Elmo TRV-S8 belts problem?
Arno Featherstone
Junior
Posts: 18
From: Seaside, CA, USA
Registered: Apr 2019


 - posted April 30, 2019 11:40 PM      Profile for Arno Featherstone   Author's Homepage   Email Arno Featherstone   Send New Private Message       Edit/Delete Post 
OK...after the cleaning the film path, the audio head, everything worked for a few reels, then this scrapy sound, not pulling thru properly, i took the back cover off - there is a lot of debris with the grease and the belts probably could do with replacing, i don't know how much play there should be in them...i did notice on the inside back cover some gritty black residue like something is grinding. this is a new feature. I don't have a lot of experience with this projector, any advice would be helpful. I don't own this unit, it's on loan and owner hasn't cared for it properly it seems to me.

--------------------
Arno

 |  IP: Logged

Arno Featherstone
Junior
Posts: 18
From: Seaside, CA, USA
Registered: Apr 2019


 - posted May 02, 2019 06:02 PM      Profile for Arno Featherstone   Author's Homepage   Email Arno Featherstone   Send New Private Message       Edit/Delete Post 
geez...did i offend someone? not a single reply to my post...

--------------------
Arno

 |  IP: Logged

Clinton Hunt
Jedi Master Film Handler

Posts: 845
From: Waharoa,North Island,New Zealand
Registered: May 2010


 - posted May 02, 2019 06:10 PM      Profile for Clinton Hunt   Author's Homepage   Email Clinton Hunt   Send New Private Message       Edit/Delete Post 
I don’t have any experience with this projector but I have learn’t a few things over the years about belts [Smile]
If they’re too loose then they will work sometimes and if they’re too tight they will either struggle to turn the wheels or will break faster than usual.
I also noticed on my Raynox silent dual projector that when the belt was too tight it made a new noise,like a rattle,so I put a slightly bigger one on.
This may not answer your question totally but at least you know someone is “out there” lol

--------------------
Cheers from me in New Zealand :-)

 |  IP: Logged

Arno Featherstone
Junior
Posts: 18
From: Seaside, CA, USA
Registered: Apr 2019


 - posted May 02, 2019 11:18 PM      Profile for Arno Featherstone   Author's Homepage   Email Arno Featherstone   Send New Private Message       Edit/Delete Post 
Thanks Clinton!
yes, i do suspect the belts, they look worn and not as taut as they should be. they're cheap enough, you just have to know how to tinker to replace.

--------------------
Arno

 |  IP: Logged



All times are Central  
   Close Topic    Move Topic    Delete Topic    next oldest topic   next newest topic
 - Printer-friendly view of this topic
Hop To:

Visit www.film-tech.com for free equipment manual downloads. Copyright 2003-2019 Film-Tech Cinema Systems LLC

Powered by Infopop Corporation
UBB.classicTM 6.3.1.2