Announcement

Collapse
No announcement yet.

Wolverine-Hawkeye Telecine

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • The spacer length calc is just a guideline. The tested spacer lengths are listed in the V14 of the manual:
    https://github.com/vintagefilmography/Hawkeye
    Yes, the image size is the actual image on the sensor.
    I use CCS application for compiling and writing the image. Looks like it uses the out file. I can check the log.

    Comment


    • Thanks Again Stan

      I installed CCS, recompiled the firmware, and found the CCS-hex utility. I have a V12 board with the 72BUC and have been performing HDR with the current fw. When running at 0.5 FPS I set the following exposure values in sequence; (1000, 2000, 3000, 4000, 5000) uSec. The trigger pulse acquires the first exposure but I found that occasionally, when you set the exposure value while hardware trigger is enabled, the exposure value used may be the previous value. From discussion with TIS support the exposure value may not be set until a trigger occurs which resulted in my stack exposure sequence being off by one with a duplicate. When you use one of the HDR functions (Debevec for example) and the camera transfer function is calculated with a hosed stack the results are very poor. The Fusion Merge functions (Mertens) are less affected but can be biased when you have two identical exposures in the stack. My best effort so far is to set exposure to the first index on start of application. Then when the triggered frame arrives I soft trigger each of the remaining exposure settings in sequence. The final step is to ensure the hardware trigger will use the correct exposure so I change exposure to 1000, soft trigger an addition frame, and discard it. I can acquire the 5 images and process the Fusion stack in ~1.3 seconds.

      The greatest problem now is poor exposure on the film. Apparently my grandfather didn't know how to set exposure correctly :-/


      Regards

      Chris

      Comment


      • Good work Chris. I had really nasty issues with the UX178 and multiple exposures for HDR. Came up with the trigger and capture pattern that worked out ok in the end but took me a while before I figured it out.

        Comment


        • Hi!

          It's been a long time since my last log in, but professional life was keeping me busy. Anyways, the problem with my jitter, which was discussed around page 87 of this thread does really have a correlation to the source material, which was suggested. I am not quite sure how to fix it, but will try anways. So I have decided to jump the line and order a hawkeye from Stan. I hope there is a way for sending it to Austria!

          Greetings!

          Comment


          • Hi Johann. I can definitely ship the Hawkeye to Austria but maybe we should look at you jitter issue one more time because there is not guarantee that the Hawkeye mod will fix your issue. Here are some ideas:
            - How old is your machine. The claw on these machines wears out and I implemented a fix with the aluminum duct tape, As the claw cam wears out the claw travel is reduced and it does not engage the film properly. I can send you the mod details.
            - Insert the film into the gate and check if it fits properly. There should be no lateral play. If the play is there then the Hawkeye mod will not help you. You should consider the deshaker post sw.
            - I would try the deshaker in any case should help with both types of jitter.
            - Undo the gate cover screws a 1/4 of a turn to increase the gate pressure. It may help.
            - Control the takeup reel pull by stopping it with your hand and letting it go for a bit so that there is always some film slack. See it that helps with jitter.

            Comment


            • Hi Stan, finally cleared my table of other projects and took the Wolverine/Hawkeye out of the box (shameful I know). Installed the driver for the 37UX178 camera, installed my lens (very sloppy thread, used Teflon tape to fix) and connected to a USB3.1 port.

              Have an image on screen, but live does not stay live for very long (it becomes static like a snapshot but live button remains selected), which makes it impossible to set things up. Is this the camera? Never had this problem with the 72buc, but yes USB2 on that one.
              Just wondering if you had this happen.

              Strange thing is if the resolution is changed it becomes live again for say 10 seconds and then goes static again.
              Is there something in settings that I am missing.
              Thanks - Bruce
              Last edited by Bruce Davis; May 10, 2021, 04:34 AM.

              Comment


              • Hi Bruce. There is nothing shameful about it. We all have our priorities. Looks like you have a USB3 issue. What cable are you using and is your computer usb3 capable? Try connecting directly to the camera with a good USB3 cable.

                Comment


                • Hi Stan, thanks for the reply, using the cable you supplied with the right angle USB-C plug. Could well be a USB3 problem will investigate further, am using an Orico superspeed+ USB3.1 PCI-Express Card (model PA31-2P), also have USB3 connectors at rear of computer from motherboard, will have to test those (will let you know).
                  Regards - Bruce

                  Comment


                  • Hi Bruce, can you connect directly to the camera i.e. bypass the jumper cable. This setup worked with my Dell Inspiron 17 laptop but maybe it does not play well with your computer. Also you can try shutting down any other apps on the computer. Perhaps reboot the computer and turn off any unnecessary apps.
                    I can also send you the USB3 heavy duty cable from TIS since I no longer use it. The postage should not be that bad.

                    Comment


                    • Good morning Stan!

                      My turn to send you another mystery. Running at the slowest speed, I get two duplicate frames. Each with unique numbers. This is very difficult to identify when each frame can have little change. Then it shows up when playback speed is slow.

                      All other speeds are working. I just noticed this with the previous reel I captured and I doubled the playback rate, rather than recapture.

                      I can't say if this just happened or I didn't notice before. Sometimes these films look better when slowed down. I don't always use just RUN.

                      For now, I'm just moving the speed up to RUN+SPEED. That removes HDR mode. I never was happy with HDR and get what I need by adjusting WDR settings, exposure, and gamma. Then tweak it in post. I think I need to better understand the extended settings in Enfuse.

                      I believe the slower the speed, the more stable the image. Adding SPEED does not cause me any problems.

                      Anyway, it's a low priority.

                      Comment


                      • Hi Stan!

                        My machine was bought on amazon and was according to the looks of the packaging and the machine itself new. BUT the counter was allready at 109. So maybe it was a repacked / refurbished unit?
                        I will check, if there is any sign of wear on the claw cam in the next few days.
                        The film itself doesn't have a noticeable play, but I will also try to loosen the screws on the gate cover.
                        The last advice you gave was tried by me before. It practically eliminates the periodic jitter, which occured, when the film was pulled and the supply reel spun a little until it stopped and the film was pulled again.

                        I'll report back with my findigs!

                        Comment


                        • Hi Stan, connected directly as you suggested and this has solved the problem, thanks for the offer regarding the TIS cable, you included one in the package that you posted. I also tried the TIS cable with the jumper cable in place and the result was the same.

                          Noticed on start up that IC capture tends to default to 30fps (in the Select a frame rate for the device) but I can change this to a max of 90fps.
                          No matter what resolution is selected or fps, in (live) mode, IC capture at the top left hand side indicates a constant 23 to 24 FPS, so I guess that is going to be the maximum transfer rate on my system.

                          Have not done any transfers as yet, just happy to get the USB3 working at this stage, perhaps the jumper cable combined with a shorter USB3 cable, in my case, might work, for now have routed the cable through the jumper cable opening in the rear cover.

                          Thank you Stan - Regards.

                          P.S. just as a point of interest, my 16mm lens in order to focus, only screws in some 2 turns, at 4-3/4 turns (as in your case) the image is considerably out of focus. It is hard to find a perfect focus point, with only 2 turns this does not leave much to play with.
                          Last edited by Bruce Davis; May 10, 2021, 07:54 PM.

                          Comment


                          • David, the slow mode automatically goes into HDR. My thinking was that the slow mode would not be normally used so I decided to use it for HDR capture which has to be slow due to two exposures.
                            But that can be easily changed in the code.


                            Just comment out the second trigger

                            Click image for larger version

Name:	msp-hdr-code-disable.jpg
Views:	72
Size:	78.5 KB
ID:	34213

                            Thanks for the feedback Johann. Let's see what condition the claw is in. The Hawkeye mod does help with the takeup pull jitter.

                            Bruce, I do not remember exactly how deep the lens in the holder when in focus. Here is the picture of your unit with the 16mm lens that I setup here before shipping it. Hope it helps.

                            Click image for larger version

Name:	IMG_20201111_202051.jpg
Views:	68
Size:	167.1 KB
ID:	34214

                            Comment


                            • Hi Stan, many thanks, have put through the first 3-1/2 minute S8 reel using the new UX178-ML camera (a reel previously done with the 72BUC02_ML).

                              Using the settings in the "Hawkeye operating guide-ux178.pdf", I am very impressed, this Sony camera does a much better job, not only with colour balance but also contrast (better balance between dark and light areas). On this reel where I previously had considerable extreme blown out whites in light areas and difficulty in getting colour to reproduce correctly (never really got that right). With the Sony there were no blown out areas at all, presumably due to a better dynamic range and your expertise in coming up with the right settings.

                              It can still be improved in post processing, currently experimenting with the "Result8" in your modified VideoFred's script. I like the result but do not know how to increase the frame rate from 18 to 25, any of the other options pick up the "numerator= 25" and produce a 25fps video but "Result8" does not.

                              Very happy - regards - Bruce

                              Comment


                              • Glad it is all working well for you Bruce. Are you trying to change the playback speed of the video from 18 to 25.
                                In the Hawkeye avs script I turned off several filters because they gave me issues at higher rez.

                                For FPS I turned of the speed change.

                                source= AviSource(film).assumefps(play_speed).trim(trim_be gin,0).converttoYV12()
                                trimming= framecount(source)-trim_end
                                source1= trim(source,0,trimming)

                                I used source1 instead of source. Source1 does not use speed change. You can change it to:
                                source1= trim(source,0,trimming).assumefps(play_speed)
                                And see if this will cause issues.
                                Best regards


                                Comment

                                Working...
                                X